Huawei SVI (Switch Virtual Interface) Konfigürasyonu
73

Huawei SVI (Switch Virtual Interface) Konfigürasyonu

VLAN’lar arası iletişim için yönlendirme (routing) işlemine ihtiyaç vardır. Bu işlem genellikle Router üzerinden yapılsa da, ihtiyaç duyulması halinde Swtich üzerinden de yapılabilir. Switch’te oluşturulan VLAN Interface’ler ile, VLAN’lar arası yönlendirme yapılabilir. Yapılan bu işlem SVI (Switch Virtual Interface) olarak adlandırılmaktadır ve konfigürasyonu da gayet kolaydır.

huawei svi topoloji

Yukarıdaki gibi basit bir topoloji üzerinden SVI yapılandırmasını yapalım. Yapılandırmaya geçmeden önce temel konfigürasyonumuzu yapalım.

Öncelikle CORE SW’de VLAN’ları oluşturup, SW1 ile olan bağlantısını Trunk port olarak yapalım.

<Huawei>system-view 
[Huawei]sysname CORE_SW
[CORE_SW]vlan batch 10 20
[CORE_SW]interface GigabitEthernet 0/0/1
[CORE_SW-GigabitEthernet0/0/1]port link-type trunk
[CORE_SW-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20

SW1’de de VLAN’ları oluşturup, portların VLAN atamasını yaptıktan sonra CORE SW ile arasındaki bağlantıyı Trunk port yapalım.

<Huawei>system-view 
[Huawei]sysname SW1
[SW1]vlan batch 10 20

[SW1]interface GigabitEthernet 0/0/1
[SW1-GigabitEthernet0/0/1]port link-type trunk  
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20
[SW1-GigabitEthernet0/0/1]quit

[SW1]interface GigabitEthernet 0/0/2
[SW1-GigabitEthernet0/0/2]port link-type access 
[SW1-GigabitEthernet0/0/2]port default vlan 20
[SW1-GigabitEthernet0/0/2]quit 

[SW1]interface GigabitEthernet 0/0/3
[SW1-GigabitEthernet0/0/3]port link-type access 
[SW1-GigabitEthernet0/0/3]port default vlan 10
[SW1-GigabitEthernet0/0/3]quit

Bilgisayarlar için ise şu şekilde bir yapılandırma yaptım:

PC1 : 192.168.10.10/24  gateway : 192.168.10.1

PC2 : 192.168.20.10/24 gateway : 192.168.20.1

Şu anki durumda PC1 ve PC2 haberleşemeyecektir. CORE SW’de VLAN Interface oluşturacağız ve bu oluşturulan interface’ler ilgili VLAN’lar için gateway olacaktır.

VLAN 10 için interface oluşturalım ve IP adresi verelim.

[CORE_SW]interface Vlanif 10
[CORE_SW-Vlanif10]ip address 192.168.10.1 255.255.255.0

VLAN 20 için interface oluşturalım ve IP verelim.

[CORE_SW]interface Vlanif 20
[CORE_SW-Vlanif20]ip address 192.168.20.1 255.255.255.0

Konfigürasyon bu kadar. Artık VLAN’lar arası yönlendirme yapılacaktır.  Yönlendirme tablosunda her iki VLAN içinde bilgiler görünecektir.

CORE SW’de display ip routing-table komutuyla yönlendirme tablosuna (Routing-table) bakalım:

huawei display ip routing-table

Yönlendirme tablosunda iki VLAN içinde bilgiler mevcut. Son olarak PC1 ile PC2 arasında ping atarak iletişim olup olmadığını test edelim.

pc1 ping test

PC’ler arası iletişimde sıkıntı yok.

Huawei SVI konfigürasyonunu yapmış olduk. Bir sonraki yazıda görüşmek üzere.

2 Yorum

    yalçın

    merhabalar elimde bir tane s5700 L3 switch var internet dağıtımını bu switch yapıyor, farklı bir lokasyonda S5300 var(aralarında Cat 6 ile Kablo Bağlı ) L2 katmanında 5300 olan switchte hem kamera bağlı hemde internete bağlı pcler var ,kamera ve pcler için ayrı vlanlar oluşturdum kamera vlan 120 internet vlan 130 internet ip leri 192.168.1.1 /24 kamera 10.10.10.1/24 şeklinde amacım S5700 Switchinde de kameralar ping atabilmek s5300 cihazında gelen internet portu trunk yapınca bu defa internet gidiyor aynı zamanda 192.168.1.1 S5700 de 100 vlanındaki ip ye sahip S5300 cihazında ip vermeden S5700 a vlan tanımlayıp o vlanı S5300 trunk portuna tanımlayarak aktarma şansım var mı teşekkürler

    31 Mart 2021 Cevapla
      Salih ALTUNTAŞ
      Salih ALTUNTAŞ

      Merhabalar,
      Daha önceki yazışmamızda modem üzerinden internete çıktığınızı söylemiştiniz. İç network trafiğini L3 switch üzerinden yapacağınız için, PC’ler için gateway olarak L3 switchte oluşturmuş olduğunuz VLAN’ın IP adresini vermeniz gerek.
      Örneğin VLANIF 130 için 192.168.1.2/24 adresini verip, PC’lere de gateway olarak 192.168.1.2 adresini verdiğiniz taktirde VLAN120 ve VLAN130’da bulunan hostlar haberleşebilecektir. Yalnız bu durumda, PC’ler gateway olarak 192.168.1.2 adresini kullandığı için internete çıkamayacaktır. Çünkü internet için çıkış IP adresimiz 192.168.1.1.
      PC’lerin internete çıkabilmesi için, L3 swtichte 192.168.1.1 adresini default-route olarak tanımlandığınızda sorun ortadan kalkacaktır.
      Kısaca;
      L3’te oluşturduğunuz VLAN IP adresini PC’lere gateway olarak tanımlamanız ve L3 te default-route olarak 192.168.1.1 adresini tanımlamanız lazım.
      Bu şekilde PC’ler internete çıkabilir ve kameralara erişebilir. Fakat, kameralar internete yine çıkamayacaktır.

      1 Nisan 2021 Cevapla

Bir cevap yazın