Cisco Router/Switch Telnet konfigürasyonu
88

Cisco Router/Switch Telnet konfigürasyonu

Telnet (Telecommunication Network – İletişim Ağı), ağ cihazlarına uzaktan bağlanmak için kullanılan bir araçtır. TCP/IP protokolünü kullanan Telnet, 23. port üzerinden haberleşmektedir. Telnet’te veriler şifrelenmeden açık metin (Clear Text) olarak iletildiğinden dolayı güvenilir değildir ve günümüzde pek kullanılmamaktadır. (Bu konumuzda her ne kadar Telnet yapılandırmasını anlatacak olsam da, günlük hayatta kesinlikle Telnet kullanılmaması gerektiğini de hatırlatmak isterim.)

cisco telnet

Kendi bilgisayarımdan Putty ile bağlantı yapabilmek için EVE-NG üzerinde yukarıdaki topolojiyi oluşturdum.

Cisco Router Telnet yapılandırması

Öncelikle routera isim ve IP adresi vererek yapılandırmaya başlayım.

Router>enable
Router#configure terminal 
Router(config)#hostname R1
R1(config)#interface ethernet 0/0
R1(config-if)#ip address 192.168.43.10 255.255.255.0
R1(config-if)#no shutdown 

Kullanıcı adı, parola ve enable parolası oluşturalım.

R1(config)#username salih password salih
R1(config)#enable secret level 15 salih

Cisco cihazlarda uzak bağlantı için vty(Virtual Teletype) yapılandırması yapılması gerekmektedir. Bu yapılandırma da iletişim tipi, açılacak oturum sayısı gibi birçok parametre bulunmaktadır. Yapılandırma yapılırken öncelikle aynı anda kaç tane oturum açılabileceği ayarlanır.

R1(config)#line vty ?
<0-4> First Line number

Parametreye baktığımızda 0-4 arasında değer girmemiz gerektiğini görüyoruz. Buda demektir ki, en fazla aynı anda 5 tane oturum açılabilmektedir. (0 değeri 1. oturumu temsil ediyor.)

Ben maksimum değeri kullanacağım.

R1(config)#line vty 0 4

Burada ilk değer başlangıç, son değer ise bitiş oturumunu belirtmekte. Böylece aynı anda 5 oturum açılabileceğini seçmiş olduk.

Oturum sayısını belirttikten sonra erişim türünü belirteceğiz. Öncelikle kullanabileceğimiz protokollere bakalım:

R1(config-line)#transport input ?
    all All protocols
    lapb-ta LAPB Terminal Adapter
    lat DEC LAT protocol
    mop DEC MOP Remote Console Protocol
    none No protocols
    pad X.3 PAD
    rlogin Unix rlogin protocol
    ssh TCP/IP SSH protocol
    telnet TCP/IP Telnet protocol
    udptn UDPTN async via UDP protocol
    v120 Async over ISDN

Kullanılabilecek çok fazla protokol var. Biz buradan protokol olarak telnet’i seçeceğiz.

R1(config-line)#transport input telnet

Son olarak girişi aktifleştireceğiz.

R1(config-line)#login local

Bu parametre ile girişin lokal kullanıcı ile yapılacağını belirttik. Şimdide yapılandırmanın çalışıp çalışmadığına bakalım.

telnet bağlantısı

telnet bağlantısı

Bağlantım başarılı bir şekilde gerçekleşti. Oluşturmuş olduğum kullanıcı adı ve şifre ile giriş yaptım. Artık cihazı uzaktan yönetebilirim.

Cisco switch Telnet yapılandırması

Switch için Telnet yapılandırmamız router’daki ile aynı olacaktır. Tek fark, Switch’lere uzaktan erişebilmek için VLAN arayüzüne ihtiyaç vardır. Bundan dolayı VLAN arayüzüne girip IP adresi vereceğiz.

Öncelikle cihaz ismini verip ardından kullanıcı adı/parola ve enable parolası oluşturalım.

Switch#configure terminal
Switch(config)#hostname SW
SW(config)#username salih password salih
SW(config)#enable secret level 15 salih

Uzaktan erişim için IP adresine ihtiyacımız olacak. VLAN arayüzüze girip IP adresi vereceğiz. Ben örneğimde default VLAN’ı yani VLAN 1’i kullanacağım.

SW(config)#interface vlan 1
SW(config-if)#ip address 192.168.43.20 255.255.255.0
SW(config-if)#no shutdown

Son olarak uzak bağlantıyı etkinleştirelim.

SW(config)#line vty 0 4
SW(config-line)#transport input telnet 
SW(config-line)#login local

Yapılandırma bu kadar. Bağlantı testimizi de yapalım.

telnet bağlantısı

Uzak bağlantımız sorunsuz bir şekilde gerçekleşti.

Neden Telnet kullanılmamalı?

Telnet’in verileri açık metin olarak ilettiğini ve bunun güvensiz olduğunu yazının başında belirtmiştim. Şimdi neden güvensiz olduğunu görelim.

Uzak bağlantıyı yaptıktan sonra switch üzerinde birkaç şey yapalım.

telnet bağlantısı

Wireshark programı ile paketleri yakalayalım ve içinde neler olduğuna bakalım:

wireshark follow tcp stream

Wireshark ile paketi yakalayıp paket detaylarına baktığımızda, yapmış olduğumuz bağlantı ile ilgili bütün bilgilerin açık bir şekilde göründüğünü görüyoruz. Verilerin açık bir şekilde iletilmesi ağ güvenliği açısından oldukça tehlike oluşturmaktadır. Bundan dolayı uzak bağlantı için Telnet kullanılmamalı, daha güvenli olan SSH tercih edilmelidir.

1 Yorum

Bir cevap yazın