SVI (Switch Virtual Interface) Yapılandırması
83

SVI (Switch Virtual Interface) Yapılandırması

Farklı ağlarda iletişim sağlayabilmek için routing yani yönlendirmeye ihtiyaç vardır. Routing işlemi sadece routerlarda değil,  Layer  3 switchlerde de yapılabilmekte. Layer 3 switchte VLAN interfaceleri oluşturarak VLAN’lar arası routing yapmak mümkün hale geliyor.

Basit bir örnek ile yapalım:

SVI layer 3 routing

PC’ler için yaptığım yapılandırma:

PC1 : 192.168.1.2/24 Gateway: 192.168.1.1

PC1 : 192.168.2.2/24 Gateway: 192.168.2.1

Öncelikle SW1’de VLAN tanımlamalarını ve port atamalarını yapalım.

SW1(config)#vlan 10
SW1(config-vlan)#vlan 20
SW1(config-vlan)#exit
SW1(config)#interface fastEthernet 0/1
SW1(config-if)#switchport access vlan 10
SW1(config-vlan)#exit
SW1(config-if)#interface fastEthernet 0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config)#interface gigabitEthernet 0/1
SW1(config-if)#switchport mode trunk

LAYER3 isimli switche geçelim. Burada da VLANları oluşturalım ve sonrasında esas konfigürasyonu yapalım.

LAYER3(config)#vlan 10
LAYER3 (config-vlan)#vlan 20
LAYER3 (config-vlan)#exit

VLAN 10 ve VLAN 20’nin interfacelerine girip IP vereceğiz. Bu IP adresleri ilgili VLAN’lar için gateway görevi görecektir. (router interface konfigürasyonu yapmakla aynı)

Yapılandırma şu şekilde olacak:

interface VLAN ID  (örneğin; interface vlan 10)

ip address [IP Adresi] [Subnet mask]   (örneğin; ip address 192.168.10.1 255.255.255.0)

LAYER3(config)#interface vlan 10
LAYER3(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
LAYER3(config-if)#ip address 192.168.1.1 255.255.255.0
LAYER3(config-if)#exit
LAYER3(config)#interface vlan 20
LAYER3(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
LAYER3(config-if)#ip address 192.168.2.1 255.255.255.0
LAYER3(config-if)#end

Son olarak configure terminalde ip routing komutunu giriyoruz ve artık VLAN’lar arası yönlendirme aktif oluyor.

show ip route komutu ile routing tablosuna bakalım.

show ip route

show ip interface brief  komutu ile de portlarımıza bakalım.

show ip interface brief

Görüldüğü gibi VLAN 10 ve VLAN 20 adında interface oluştu ve bunlarında IP adresleri var. Bu IP adresleri ilgili VLAN’lar için gateway görevi görüyor.

Şimdi PC’ler arası ping atalım.

ping

192.168.1.2’den 192.168.2.2’ye ping atabildim.  Routing işlemi tamamlandı. SVI (Switch Virtual Interface) işlemi bu kadar basit.

Benzer Yazılar

1 Yorum

Bir cevap yazın