Router RIP (Routing Information Protocol)

Router RIP (Routing Information Protocol)

Routing Information Protocol

 

RIP (Routing Information Protocol – Yönlendrime Bilgisi Protokolü) :  

Distance vector (uzaklık vektörü) protokolene göre çalışan, komşu routerların 30 saniyede bir routing tablolarını birbiriyle paylaştığı protokoldür. Bu protokolde, uzaklık vektörü hop sayısına göre yani aşılan cihaz sayısına göre belirlenir ve en fazla hop sayısı 15’tir. Bu yüzden küçük ağlarda elverişli iken, büyük ağlarda topoljinin tamamını bilmemesinden ve 30 saniyede bir tabloların paylaşılmasının yapacağı trafikten dolayı tercih edilmez.

Küçük bir uygulama ile RIP konfigürasyonu yapalım. 

 

Router RIP

Öncelikle PC’lere gerekli ayarları yapıyoruz.

PC0 için;

IP : 192.168.5.2

Subnet : 255.255.255.0

Gateway : 192.168.5.1

 

PC1 için;

IP : 192.168.10.2

Subnet : 255.255.255.0

Gateway : 192.168.10.1

 

Şimdi routerların portlarını(interface) aktif hale getiriyoruz.

Router0 gigabitEthernet 0/0 için;

Router0(config)#interface gigabitEthernet 0/0

Router0(config-if)#ip address 5.5.5.1 255.255.255.0

Router0(config-if)#no shutdown

 

Router0 gigabitEthernet 0/1 için;

Router0(config)#interface gigabitEthernet 0/1

Router0(config-if)#ip address 192.168.5.1 255.255.255.0

Router0(config-if)#no shutdown

 

Router1 gigabitEthernet 0/0 için

Router1(config)#interface gigabitEthernet 0/0

Router1(config-if)#ip address 5.5.5.2 255.255.255.0

Router1(config-if)#no shutdown

 

Router1 gigabitEthernet 0/1 için

Router1(config)#interface gigabitEthernet 0/1

Router1(config-if)#ip address 10.10.10.1 255.255.255.0

Router1(config-if)#no shutdown

 

Router2 gigabitEthernet 0/0 için

Router2(config)#interface gigabitEthernet 0/0

Router2(config-if)#ip address 192.168.10.1 255.255.255.0

Router2(config-if)#no shutdown

 

Router2 gigabitEthernet 0/1 için

Router2(config)#interface gigabitEthernet 0/1

Router2(config-if)#ip address 10.10.10.2 255.255.255.0

Router2(config-if)#no shutdown

 

Portlarımızı açtıktan sonra show ip route komutu ile routing tablomuza bakalım.

show ip route

show ip route

show ip route

Görüldüğü gibi routerlar lokalde bağlı olduğu networkleri görüyorlar. Lokalde olmayan networkleri de tanımlayabilmeleri için RIP protokolünü aktif edeceğiz. Böylece routerlar birbirlerine routing tablolarını gönderecekler.

Öncelikle konfigürasyon terminalinde router rip komutu ile RIP protokolünü aktifleştiriyoruz. Ardından routerda tanımlı networkleri, netwrok komutu ile giriyoruz.

Router0(config)#router rip

Router0(config-router)#network 5.5.5.0

Router0(config-router)#network 192.168.5.0

router rip

Router1(config)#router rip

Router1(config-router)#network 5.5.5.0

Router1(config-router)#network 10.10.10.0

router rip

Router2(config)#router rip

Router2(config-router)#network 10.10.10.0

Router2(config-router)#network 192.168.10.2

router rip

Routerların route t ablosuna baktığımızda artık daha fazla network hakkında bilgimiz olduğunu göreceğiz. Router0 routerını incelersek, 10.0.0.0 ve 192.168.10.0 networkünü RIP protokolü sayesinde keşfettiğini görebiliyoruz.

show ip route

Son olarak PC0’dan PC1’e ping atarak yönlendirmemizin çalışıp çalışmadığını görebiliriz.

ping atma

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir