Router on a Stick (RoaS) Yapılandırması

Router on a Stick (RoaS) Yapılandırması
By Network
Oca 03

Router on a Stick (RoaS) Yapılandırması

Daha önceki yapılandırmalarda her network için routerın bir interfacesini kullanıyorduk. Tabii her network için bir interface kullanma şansımız olmayabilir. Özellikle oluşturacağı maliyetten dolayı tercih edilmeyebilir. Bu gibi durumlarda imdata routing on a stick yetişiyor. Bu yöntem sayesinde bir interface üzerinde sanal interfaceler oluşturarak birden fazla network için gateway oluşturabiliyoruz.

Küçük bir örnek ile VLAN’lar arası yönlendirmeyi tek bir interface üzerinden yapalım.

Routing on a Stick
Routing on a Stick

Yukarıdaki gibi bir yapımız olsun. Ben PC0 için 192.168.10.5, PC1 için 192.168.20.5 IP adresini kullanacağım. Switch yapılandırmasını hemen kısaca yapalım;

Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport access vlan 10
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 20
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk

Şimdi gelelim routerdaki yapılandırmaya. gigabitEthernet 0/0/0 interfacesi için sanal interfaceler oluşturacağız ve bu interfacelerin VLAN kapsülleme protokolünü belirttikten sonra IP adreslerini gireceğiz.

Interfaceyi oluşturmak için interface gigabitEthernet 0/0/0 yazdıktan sonra . (nokta) koyup sanal interface için ID belirtiyoruz. İstenilen ID verilebilir ama VLAN ile aynı ID’de olması konfigürasyon okuması yaparken işimizi kolaylaştırır.


Önce interfaceyi oluşturuyoruz.

Router(config)#interface gigabitEthernet 0/0/0.10

Ardından kapsülleme protokolünü seçiyoruz ve VLAN ID’yi yazıyoruz.

Router(config-subif)#encapsulation dot1Q 10

Sonra ip adresi tanımlıyoruz.

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Aynı işlemleri VLAN 20 için de yapıyoruz.

Router(config)#interface gigabitEthernet 0/0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Son olarak asıl interfacemizi açıyoruz.

Router(config)#interface gigabitEthernet 0/0/0
Router(config-if)#no shutdown

Komutu yazdıktan sonra  komut satırında asıl interfacenin ve sanal interfacelerin açıldığına dair bildiri gelecektir.

Artık routerdeki tek interface üzerinden VLAN yönlendirmelerini yapılacak ve network sorunsuz bir şekilde çalışacaktır.

Click to rate this post!
[Total: 1 Average: 5]

Author: Salih ALTUNTAŞ

Cisco CCNA ve Huawei HCIA hakkında blog içerikleri üretmekteyim.

Comments (9)

  1. Ali Şub 20 2020 - 16:13

    Hocam böyle faydalı bir içeriği paylaştığınız için teşekkür ederim.

  2. Fatih May 24 2021 - 14:06

    Merhaba hocam ,

    Şöyle bir lab kurdum.

    Elimde , 2 adet switch ve 1 adet router ve 6 adet PC var.

    Kat 1 Switch ‘ inde vlan 10 yapısı var ve bu yapıya 3 tane pc bağlı.
    Kat 2 Switch’inde vlan 20 yapısı var ve bu yapıya da 3 tane pc bağlı.

    Bu iki switch’e bağlı bilgisayarların birbirlerini görebilmesi için Router On Stick yapısını nasıl kullanabilirim ?
    Her iki switchden de ayrı ayrı kablo ile router a bağladım ve router on stick yapısını sorunsuz bir şekilde kullandım.
    Ama benim merak ettiğim iki switchi birbirine bağlayıp bu işlemi yapmak.
    Bu yapıyı Router On Stick ile yapabilir miyim?
    Teşekkürler.
    İyi çalışmalar.

    • Salih ALTUNTAŞ May 24 2021 - 23:19

      Merhaba,
      her iki switch’i birbirine bağlayarak RoaS yapmanız mümkün. Her iki switchte de VLAN tanımlamalarını yapıp, switchler arası bağlantıyı trunk port olarak yapılandırmanız yeterli olacaktır.

  3. isimsiz May 27 2021 - 19:15

    Merhaba ,
    Dediğiniz gibi trunk yaptım. Ama olmadı. Bende
    trunk olan portlarda switchport trunk allowed vlan 10,20,30 komutunu kullandım ve ping başarılı bir şekilde atıldı.
    Teşekkürler.

    • Salih ALTUNTAŞ May 27 2021 - 20:05

      Merhaba,
      Evet trunk yaptıktan sonra geçecek VLAN’ları belirtmek gerek. (Gerçi Cisco’da trunk port yapınca tüm VLAN’ların geçişine izin veriliyor. Ondan dolayı belirtmemiştim.) Neyse ki sorunu çözmüşsünüz.

  4. Baran Haz 30 2022 - 13:39

    İyi günler
    Roas ve Dinamik nat ayarını aynı router üzerinde yapabilir miyiz ?

    • Salih ALTUNTAŞ Tem 02 2022 - 13:18

      Merhaba,
      Aynı router üzerinde dinamik NAT ve RoaS işlemini yapabilirsiniz. Bunu yapmak için, her subinterface’de kullanılmak üzere NAT Pool ve ACL oluşturmanız gerekecektir.

  5. ahmet görkem alan Tem 22 2022 - 14:05

    merhabalar iyi günler elimde 7 adet vlan bulunmakta ve bu vlanlardan biri yönetim vlanı. yönetim vlanımın bütün cihazlara erişiminin olmasını istiyorum diğer 6 adet vlanımın da kendi içinde iletişim kurabilmesi gerek nasıl yapılabilir acaba.

    • Salih ALTUNTAŞ Tem 24 2022 - 17:04

      Merhaba,
      Tüm VLAN’ları bu yazıdaki gibi subinterface’de yapacaksanız sorun yaşamazsınız. Router-Switch arası bağlantıda, switch tarafında bulunan portun trunk port olması gerekiyor.

Leave your Comment