network address translation

NAT (Network Address Translation)

NAT (Network Address Translation – Ağ Adresi Çevirisi)

Ipv4’te kullanılabilir olan IP adresi 3 milyardan fazla. Yerelde ve geniş ağ bağlantılarını hesaba kattığımızda bu IP adreslerinin yetmeyeceği malum. Bundan dolayı yerel (LAN) ağlardaki cihazların dış ağlara çıkarken her cihazın kendi IP’sini kullanmak yerine bir ya da birkaç IP ile çıkması sağlanarak IP yetersizliğinin önüne geçilmiş olundu.

Kısaca NAT, networkte bulunan hostların kendi IP’leriyle değil belirlenen IP ile çıkmalarını sağlar. Bu IP’ler ISS’lerden (Intenet Servis Sağlayıcı) temin edilir.

Statik NAT yapılandırması

Bu yapılandırmada ağda bulunan hostlar için tek tek çıkış IP’si belirlenir. Tabii öncelikle routerda da hangi interfacenin giriş hangisini çıkış olduğu ayarlanmalıdır.

statik nat

Yukarıdaki basit örnek içim statik NAT oluşturalım. Tabii NAT işleminden önce host ve routerlarda gerekli yapılandırmaların yapılmış olması gerekiyor.

Router0 için routing yapılandırması;

Router0(config)#interface gigabitEthernet 0/0/0

Router0(config-if)#ip address 192.168.20.1 255.255.255.0

Router0(config-if)#no shutdown

Router0(config)#interface serial 0/1/0

Router0(config-if)#ip address 1.1.1.1 255.255.255.252

Router0(config-if)#no shutdown

Router0(config)#ip route 192.168.10.0 255.255.255.0 1.1.1.2

Router1 için routing yapılandırması;

Router1(config)#interface gigabitEthernet 0/0/0

Router1(config-if)#ip address 192.168.10.1 255.255.255.0

Router1(config-if)#no shutdown

Router1(config)#interface serial 0/1/0

Router1(config-if)#ip address 1.1.1.2 255.255.255.252

Router0(config-if)#no shutdown

Router1(config)#ip route 192.168.20.0 255.255.255.0 1.1.1.1

Router0 statik NAT yapılandırması;

Router0(config)#interface gigabitEthernet 0/0/0

Router0(config-if)#ip nat inside (gigabitEthernet 0/0/0 interfacesini giriş tarafı olarak seçmiş olduk)

Router0(config)#interface serial 0/1/0

Router0(config-if)#ip nat outside (serial 0/1/0 interfacesini çıkış tarafı olarak seçmiş olduk)

Router0(config)#ip nat inside source static 192.168.20.10 1.1.1.1 (192.168.20.10 IP adresinin ağ dışına çıktığında 1.1.1.1 IP adresiyle görünmesini sağladık)

PC0’dan Server0’a ping atalım ve ardından NAT tablosuna bakalım.

show ip nat translations  komutuyla Router0’da gerçekleşen NAT işlemlerine bakalım.

show ip nat translations

Tabloya baktığımızda lokaldeki 192.168.20.10 adresinin, 1.1.1.1 adresiyle 192.168.10.10 adresine ulaştığını görüyoruz.

Dinamik NAT 

dinamik nat

Dinamik NAT’ta, statik NAT gibi tek tek IP adresi girmek yerine kullanılabilecek IP adresleri için havuz oluşturuluyor. Böylece, router havuzdan otomatik olarak kullanılacak IP’yi seçiyor. Ayrıca hangi networkteki hangi IP adreslerinin çıkışına da izin verileceğini belirtmek için access-list oluşturulması gerekiyor.

Router0(config)#access-list 1 permit 192.168.20.0 0.0.0.255  (1 numarasını verdiğim ACL oluşturdum ve 192.168.20.0 networkundeki tüm IP’lerin geçmesine izin verdim)

Router0(config)#ip nat pool NAT 1.1.1.3 1.1.1.7 netmask 255.255.255.0 (Ağ dışına çıkışta kullanılabilecek IP aralığı için 1.1.1.3-1.1.1.7 arasında havuz oluşturdum.)

Router0(config)#ip nat inside source list 1 pool NAT (oluşturmuş olduğum ACL ve IP havuzunu  router giriş yönünde uygulanması için ekledim)

Her iki bilgisayardan da ping atalım ve daha sonra show ip nat translations  komutuyla Router0’da gerçekleşen NAT işlemlerine bakalım.

show ip nat translations

Tabloya baktığımızda 192.168.20.10 IP adresli PC’nin  hedef PC’ye 1.1.1.3 IP adresiyle, 192.168.20.11 IP adresli PC’nin hedef PC’ye 1.1.1.7 IP adresiyle ulaştığını görüyoruz.

clear ip nat translation *  komutuyla da translation tablosunu silebiliriz.

clear ip nat translation

 

salih

hazırlanıyor...

Yorum Bırak

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir