Huawei Yedekli Statik Yönlendirme (Floating Static Routing) Konfigürasyonu
192

Huawei Yedekli Statik Yönlendirme (Floating Static Routing) Konfigürasyonu

Bir önceki yazımızda Huawei Statik Yönlendirme (Static Routing) konusunu işlemiştik. İşlediğimiz konuda Router Interface IP verme ve statik rota yazım şekillerini gördük. Aslında bu örneğimizde aynı örnek üzerinden gideceğiz. Tek fark, routerlar arasında bir bağlantı daha ekleyeceğiz ve bu bağlantıyı yedek olarak kullanacağız. Yedekliliğin düzgün çalışması için de preference değerini değiştirerek yapacağız. Bu yöntem floating static routing olarak adlandırılmakta. Biz buna yedekli statik rota diyelim ve aşağıdaki basit topoloji ile konfigürasyonumuzu yapalım.

huawei static route redundancy

R1 için interface yapılandırması:

<Huawei>system-view 
[Huawei]sysname R1
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.1 255.255.255.0
[R1-GigabitEthernet0/0/1]undo shutdown
[R1-GigabitEthernet0/0/1]quit
[R1-GigabitEthernet2/0/0]ip address 10.10.11.1 255.255.255.252 
[R1-GigabitEthernet2/0/0]undo shutdown 
[R1-GigabitEthernet2/0/0]quit 
[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.252
[R1-GigabitEthernet0/0/0]undo shutdown
[R1-GigabitEthernet0/0/1]return 
<R1>save

R2 için interface yapılandırması:

<Huawei>system-view 
[Huawei]sysname R2
[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 192.168.1.2 255.255.255.0
[R2-GigabitEthernet0/0/1]undo shutdown
[R2-GigabitEthernet0/0/1]quit
[R2-GigabitEthernet2/0/0]ip address 10.10.11.2 255.255.255.252 
[R2-GigabitEthernet2/0/0]undo shutdown 
[R2-GigabitEthernet2/0/0]quit 
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 10.10.10.2 255.255.255.252
[R2-GigabitEthernet0/0/0]undo shutdown
[R2-GigabitEthernet0/0/1]return 
<R2>save

Yapacağımız işlem çok basit. Hedef ağ için şu an elimde iki tane yol var. Bu iki yol için statik rota yazacağım ve bunlardan bir tanesinin preference değerini düşük bir değer vererek rotanın bu yol olmasını sağlayacağım. Birinci yolda bir problem olması durumunda diğer statik rota işlemeye başlayacak ve iki ağ arasında bağlantı devamlılığı sağlanacak.

Ben 10.10.10.0’lı networkü birincil (primary), 10.10.11.0’lı networkü yedek olarak kullanacağım. Huawei routerlarda statik route preference değeri default olarak 60’tır. Bu bilgiye dayanarak birinci yolun pereference değerini düşürerek ya da ikinci yolun preference değerini yükselterek, yol seçimini sağlayabilirim.

Hatırlatma : Preference değeri düşük olan yol, rota olarak seçilir.

Router 1 için, birinci yolun prefence değerini düşük yazarak birincil yol olmasını sağlayacağım.

[R1]ip route-static 192.168.2.0 24 10.10.10.2 preference 10
[R1]ip route-static 192.168.2.0 24 10.10.11.2

Statik rotaya bakalım display ip routing-table protocol static 

display ip routing-table protocol static

Tabloya baktığımızda 2 tane statik rotanın olduğu ama preference değeri düşük olanın aktif, preference değeri yüksek olanın ise inaktif olduğunu görüyoruz.

Router 2 için de iki tane rota yazalım. Bu sefer birinci yol için preference değeri girmeyeceğim ve default olarak 60 değerini alacak. İkinci yol için ise preference değerini 60’tan büyük bir sayı vererek, birinci yolun aktif yol olmasını sağlayacağım.

[R2]ip route-static 192.168.1.0 24 10.10.10.1
[R2]ip route-static 192.168.1.0 24 10.10.11.1 preference 70

Router 2’nin statik rotasına bakalım display ip routing-table protocol static 

display ip routing-table protocol static 

Yine yaptığımız işlemle birinci yolun 10.10.10.0’lı network olmasını sağladık. Şimdi PC’ler arası trace yaparak hangi yoldan gittiğini görelim.

pc tracert

PC1 ile Pc2’nin 10.10.10.0’lı networkten haberleştiğini gördük. Şimdi birincil yolda problem olduğunda yedek yolun çalıştığını görmek için birinci yolun portunu kapatacağım.

[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]shutdown

Portu kapattıktan sonra tekrardan PC1’den trace çekeceğim.

pc tracert

Route tablomuza da bakalım.

display ip routing-table protocol static

Görüldüğü üzere yedek yol devreye girdi ve bağlantı devamlılığı sağlandı. 2 tane statik  rota yazarak yedekliliği sağlamış olduk. Birinci yolun portunu aktif ettiğim an devreye girecek ve ana yol olarak iletişimin kurulmasını sağlayacaktır.

Benzer Yazılar

Bir cevap yazın