Huawei switch VLAN konfigürasyonu
131

Huawei switch VLAN konfigürasyonu

Bu yazımda Huawei switchlerde temel VLAN işlemlerini göreceğiz. Huawei swtichlerde tanımlanabilir VLAN aralığı 1-4094 şeklindedir. Tüm üreticilerde olduğu gibi default VLAN 1’dir; bu VLAN silinemez, silinmesi teklif dahi edilemez 🙂

Huawei switchlerde default port tipi Hybrid’dir. Bu port tipinde istenilen sayıda VLAN’lar etiketli (TAGGED) ve etiketsiz (UNTAGGED) olarak geçirilebilir. Yani bir nevi port hem access hemde trunk gibi kullanılabiliyor diyebiliriz.

Huawei’de VLAN ataması 5 şekilde yapılabilir: port bazlı, MAC adresi bazlı, IP Subnet bazlı, protokol bazlı ve politika bazlı. Tabii bunlardan en fazla tercih edileni port bazlı atama olması ve aşinalık olmasından dolayı genelde port bazlı ile işlemler yapılıyor. Ama diğer yöntemlerin de olduğunu bilmekte fayda var.

Atama türü VLAN ID
Port Bazlı GigabitEthernet 0/0/1, GigabitEthernet 0/0/4
MAC adresi bazlı  AA-BB-CC-11-22-33
IP Subnet bazlı 192.168.1.*
Protokol bazlı IP – IPX
Politika bazlı AA-BB-CC-11-22-33 + GigabitEthernet 0/0/4 +  192.168.1.*

 

Huawei VLAN oluşturma

system-view modunda iken vlan ID şeklinde VLAN oluşturulabilir. Örnek olarak VLAN 10 oluşturalım ve açıklamasını BT_Personel yapalım.

<Huawei>system-view 
[Huawei]vlan 10
[Huawei-vlan10]description BT_Personel

Huawei çoklu VLAN oluşturma

Huawei’de çoklu vlan oluşturmak için vlan batch komutu kullanılır ve komuttan sonra ID’ler aralarında boşluk bırakılarak peş peşe yazılır. Örnek olarak 5,8 ve 17 nolu VLAN’ları oluşturalım.

[Huawei]vlan batch 5 8 17

Eğer sıralı bir şekilde VLAN oluşturulmak isteniyorsa ID’ler arasına to komutu eklenerek aralık belirlenir. Örnek olarak 20 ile 30 arasında VLAN oluşturalım.

[Huawei]vlan batch 20 to 30

Eğer hem tekli hem de aralıklı VLAN oluşturulmak isteniyorsa üstte belirttiğim iki örneği harmanlayacağız.  Örnek olarak 36,37, 45-50, 52,61, 70-80 VLAN’larını oluşturalım.

[Huawei]vlan batch 35 36 45 to 50 52 61 70 to 80

Huawei VLAN görüntüleme

Eee bu kadar VLAN oluşturduk, bunları nasıl göreceğiz derseniz eğer:

[Huawei]display vlan

huawei display vlan

Bir tane VLAN’ının detaylarını görmek için; display vlan ID

[Huawei]display vlan 10

huawei display vlan id

Belirli bir aralıktaki VLAN’ları görüntülemek için; display vlan ID to ID

[Huawei]display vlan 10 to 20

huawei display vlan id to id

Huawei VLAN silme

Tek bir VLAN’ı silmek için: undo vlan ID

[Huawei]undo vlan 5

Aralık belirterek VLAN silmek için: undo vlan batch ID to ID

[Huawei]undo vlan batch 10 to 20

Tüm VLAN’lar silmek için yine batch komutundan yararlanacağız.  Bu sefer aralığı tüm VLAN’ları kapsayacak şekilde yapacağız.

[Huawei]undo vlan batch 2 to 4094

Huawei VLAN konfigürasyonu

huawei vlan konfigürasyonu

Yukarıdaki basit örnek üzerinden yapılandırmalar yapacağız.  Tabii şu anki durumda VLAN’lar arası iletişim olmayacak, sadece aynı VLAN’da olan PC’ler haberleşebilecek.

Porta VLAN atama

LSW1 switchinden başlayalım; Cihaz ismini değiştirdikten sonra VLAN 10 ve VLAN 20’yi oluşturup, bu VLAN’ları ilgili portlara tanımlamasını yapacağım. Yazının başında Huawei’de 5 farklı şekilde VLAN ataması yapılabildiğinden bahsetmiştim. Her ne kadar 5 farklı yöntem olsa da, genellikle port bazlı atama tercih edildiği için bu yöntem ile işlemleri yapacağım. Belki başka bir yazıda bunları da yazarım.

Port bazlı atama yapmak için portun arayüzüne girilir, link tipi access olarak belirlenir ve kullanılacak olan VLAN belirlenir.

<Huawei>system-view
[Huawei]sysname SW1
[SW1]vlan batch 10 20
[SW1]interface GigabitEthernet 0/0/2
[SW1-GigabitEthernet0/0/2]port link-type access
[SW1-GigabitEthernet0/0/2]port default vlan 10

Port atmasını yaptık. Şimdi interface içindeyken sihirli komutumuz olan display this komutunu kullanalım ve interface yapılandımasını görüntüleyelim.

[SW1-GigabitEthernet0/0/2]display this

huawei display this

GE 0/0/3 portunu da VLAN 20’ye atayalım;

[SW1]interface GigabitEthernet 0/0/3
[SW1-GigabitEthernet0/0/3]port link-type access 
[SW1-GigabitEthernet0/0/3]port default vlan 20

Portu trunk yapma

SW1 switchinde GE 0/0/1 portunu trunk yapalım ve bu swtichte işimiz bitsin. Interface’de port tipini belirttikten sonra hangi VLAN’ların geçeceğini belirteceğiz. Huawei’de portu trunk moda çekince ön tanımlı olarak tüm VLAN’ların geçişine izin vermiyor; bundan dolayı geçişi sağlanacak VLAN’ları eklemek gerekiyor.

[SW1]interface GigabitEthernet 0/0/1
[SW1-GigabitEthernet0/0/1]port link-type trunk 
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20

tüm VLAN’ların geçmesine izin verilmek isteniyorsa;

[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all

SW1’de tüm işlerimiz bitti, VLAN’ların durumuna bakalım.

huawei display vlan

Çıktıya bakıldığında VLAN10’un GE 0/0/2 portunda (UT) UNTAG, GE 0/0/1 portunda ise TAG (TG)  olduğu; VLAN 20’nin ise GE 0/0/3 portunda (UT) UNTAG, GE 0/0/1 portunda ise TAG (TG) olduğu görünmektedir.

SW2 içinde konfigürasyonumuzu yapalım:

<Huawei>system-view 
[Huawei]sysname SW2
[SW2]vlan batch 10 20
[SW2]interface GigabitEthernet 0/0/1
[SW2-GigabitEthernet0/0/1]port link-type trunk 
[SW2-GigabitEthernet0/0/1]port trun allow-pass vlan 10 20
[SW2-GigabitEthernet0/0/1]quit 
[SW2]interface GigabitEthernet 0/0/2
[SW2-GigabitEthernet0/0/2]port link-type access
[SW2-GigabitEthernet0/0/2]port default vlan 10
[SW2-GigabitEthernet0/0/2]quit
[SW2]interface GigabitEthernet 0/0/3
[SW2-GigabitEthernet0/0/3]port link-type access
[SW2-GigabitEthernet0/0/3]port default vlan 20

Her şey tamam. Şu an aynı VLAN’da olan PC’ler aynı networkte oldukları taktirde haberleşecektir ama yine de bir testimizi yapalım. PC1 : 192.168.1.10/24, PC2: 192.168.2.10/24, PC3:192.168.1.11/24 ve PC4: 192.168.2.11 şeklinde IP adreslerini verdim.

huawei vlan config ping

Sorunsuz bir şekilde aynı VLAN’lar haberleşti. Farklı VLAN’ların haberleşmesi için routing (yönlendirme) gerekmektedir. VLAN’lar arası haberleşmeye ilerleyen konularda değineceğim.

Bir cevap yazın