Huawei Statik Yönlendirme (Static Routing) Konfigürasyonu
232

Huawei Statik Yönlendirme (Static Routing) Konfigürasyonu

Bu yazımızda basit bir topoloji üzerinden statik yönlendirme (static routing) nasıl yapılır onu göreceğiz. Statik yönlendirme, hedef ağa ulaşmak için seçilecek yolun manuel belirtilmesidir. Bu yol belirtilirken hedef ağa gidilebilecek atlama noktası (next hoop) ya da çıkış arayüzü (interface) yazılarak yapılabilir.

huawei static routing configuration

Statik yönlendirmeye geçmeden önce yönlendirici (router) ve bilgisayarlarda ayarlarımızı yapalım. R1 için yapılandırma:

<Huawei>system-view 
[Huawei]sysname R1
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.1 255.255.255.0
[R1-GigabitEthernet0/0/1]undo shutdown
[R1-GigabitEthernet0/0/1]quit
[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 10.10.10.1 255.255.255.252
[R1-GigabitEthernet0/0/0]undo shutdown

R2 için interface yapılandırması aşağıdaki gibi olacaktır. R1’de interface yapılandırmasında subneti oktetli bir şekilde yazmıştım. Huawei’nin en güzel yanlarından birisi de subneti ondalık olarak yazabilmemiz. R2’de subneti ondalık olarak yazacağım.

<Huawei>system-view 
[Huawei]sysname R2
[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 192.168.2.1 24
[R2-GigabitEthernet0/0/1]undo shutdown 
[R2-GigabitEthernet0/0/1]quit
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 10.10.10.2 30
[R2-GigabitEthernet0/0/0]undo shutdown

Statik yönlendirmemizi yapalım. R1 yönlendiricisinde (router) 192.168.1.0 ağı (network) ve 10.10.10.0 ağı (network) direkt bağlı olduğu için bu ağlar arasında haberleşme konusunda sıkıntı olmayacaktır. R2’nin arkasında kalan 192.168.2.0 ağını ise R1’e öğretmemiz gerekecek. 192.168.2.0 ağı için 2 şekilde rota yazabiliriz; ya bir sonraki noktayı belirteceğiz (next hoop) ya da R1’in çıkış arayüzünü (interface) belirteceğiz. R1’den statik rota yazarken next hoop belirterek yapacağım.

[R1]ip route-static 192.168.2.0 255.255.255.0 10.10.10.2

R2’den R1’e statik rota yazarken bu sefer hedef ağ için yolu interface olarak belirteceğim. R2’den 192.168.10.0 ağı için R2’nin GigabitEthernet 0/0/0 interfacesini kullanmak yeterli olacaktır. Örnek olsun diye hedef ağın subnetini bu sefer ondalık olarak gireceğim.

[R2]ip route-static 192.168.1.0 24 GigabitEthernet 0/0/0

İşlem bu kadar basit,  route tablosuna bakalım.

huawei display ip routing-table

NOT : Statik rota interface olarak belirtildiğinde preference değeri değiştirilememektedir. Bu yüzden next hoop adresi belirtilerek rotanın yazılması daha uygun olacaktır. Ayrıca Huawei’de statik rotanın preference değeri 60’tır.

Sadece statik routing tablosuna bakmak için display ip routing-table protocol static komutu kullanılır.3

huawei display ip-routing-table protocol static

Bir cevap yazın