Huawei Router on a Stick (Inter VLAN Routing) Yapılandırması

single-image

Şunu biliyoruz ki; her VLAN bir Broadcast Domaindir ve her Broadcast Domain de ayrı bir networktür. Ve şunu da biliyoruz ki, farklı networklerin haberleşmesi için routing (yönlendirme) işlemine ihtiyaç vardır. Routerlarda her network için ayrı bir interface kullanılarak routing yapılmak istense de, network sayısının fazla olması ve interface sayısının bunu karşılayamayacak durumda olmasından dolayı, sub-interface oluşturarak bu duruma çözüm bulunabilir.

Bunu yapmak için ise interfacede sub-interface oluşturulur. Oluşturulan bu sub-interface VLAN için gateway görevi görecektir, bundan dolayı her sub-interface için IP adresi verilecektir. Ayrıca, routerlar VLAN’ları enkapsüle etmediği için, interfacede enkapsülleme aktif edilir. Basit bir topoloji üzerinden yapılandırmayı yapalım.

huawei router on a stick (inter vlan routing)

Öncelikle switch üzerindeki konfigürasyonu yapalım;

<Huawei>system-view 
[Huawei]sysname SW1
[SW1]vlan batch 10 20

[SW1]interface GigabitEthernet 0/0/1
[SW1-GigabitEthernet0/0/1]port link-type trunk
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[SW1-GigabitEthernet0/0/1]quit

[SW1]interface GigabitEthernet 0/0/2
[SW1-GigabitEthernet0/0/2]port link-type access 
[SW1-GigabitEthernet0/0/2]port default vlan 10
[SW1-GigabitEthernet0/0/2]quit 

[SW1]interface GigabitEthernet 0/0/3
[SW1-GigabitEthernet0/0/3]port link-type access 
[SW1-GigabitEthernet0/0/3]port default vlan 20
[SW1-GigabitEthernet0/0/3]quit

Router üzerindeki yapılandırmamıza başlayalım. Sub-interface oluşturmak için asıl interfaceden sonra nokta (.) konulur ve bir ID verilir. Bu ID’nin VLAN ID ile aynı olmasına gerek yoktur fakat konfigürasyon okunurken daha kolay olması açısından VLAN ID ile aynı olması daha iyi olacaktır.

<Huawei>system-view 
[Huawei]sysname RT1
[RT1]interface GigabitEthernet 0/0/0.10  (sub-interface oluşturuldu)

Ardından hangi VLAN için enkapsülleme yapılacağı belirtilir.

[RT1-GigabitEthernet0/0/0.10]dot1q termination vid 10

interfaceye IP adresi verilir. Bu IP adresi ilgili VLAN için gateway olacaktır.

[RT1-GigabitEthernet0/0/0.10]ip address 192.168.10.1 255.255.255.0

Son olarak VLAN’lar arası routing (yönlendirme) çalışması için arp braodcast aktif edilir.

[RT1-GigabitEthernet0/0/0.10]arp broadcast enable

Aynı işlemi VLAN 20 için de yapacağız.

[RT1]interface GigabitEthernet 0/0/0.20
[RT1-GigabitEthernet0/0/0.20]dot1q termination vid 20
[RT1-GigabitEthernet0/0/0.20]ip address 192.168.20.1 255.255.255.0
[RT1-GigabitEthernet0/0/0.20]arp broadcast enable

Bilgisayarlara da gerekli ayarlar yapılıp konfigürasyonun doğruluğunu test edelim.

huawei router on a stick (inter vlan routing)

192.168.20.10 IP’sine sahip bilgisayardan 192.168.10.10 IP adresine ping atalım:

huawei router on a stick (inter vlan routing)

4 Comments
  1. yalçın 5 ay ago
    Reply

    merhaba sanal pc olarak kullandıgınız uygulama hangisidir teşekkürler

    • Merhaba, örnekte kullanmış olduğum sanal PC, ENSP programı içerisinde bulunmaktadır.

  2. barış gülboy 4 ay ago
    Reply

    Merhaba ar109 4g router ge1 ge2 ge3 portlarını ayrı vlanlar yapmak ve dhcp açmak istiyorum ge0 portundan tüm vlanlara erişmek birde 4g,vdsl ge4 üzerinden tüm portları internete çıkarabilmek isitoyrum bu mümkün olabilirmi acaba
    teşekkür ederim

    • Merhaba, tüm portları internete çıkarabilmek için VDSL IP bloğuna NAT yapmak lazım. Teorik olarak bu şekilde çıkış yapabilirsiniz ama MODEM bu işlemi yer mi bilmiyorum. Diğer sorunuz için de tam olarak network topolojisini bilmek lazım. Şu an ki durumda net olarak erişim olur ya da olmaz diyemem.

Leave a Comment

Your email address will not be published.

You may like