Huawei OSPF konfigürasyonu (Single Area)
131

Huawei OSPF konfigürasyonu (Single Area)

Huwaei routerlarda single area OSPF yapılandırmasını bu yazımızda işleyeceğiz. Yapılandırmaya geçmeden önce kısaca OSPF (Open Shortest Path First – İlk Açık Yöne Öncelik) hakkında bazı şeyleri hatırlayalım. OSPF,  portların bant genişliğine (band width) göre maliyet hesabı çıkartıp, aldığı paketi hedef ağ için en hızlı yoldan göndermeyi amaçlayan dinamik yönlendirme protokolüdür. AREA mantığı ile çalışır ve bulunan alanda bir tane AREA 0 olmalıdır.

huawei single area ospf

OSPF yapılandırmasına geçmeden önce, temel yapılandırmayı yapalım.

R1

<Huawei>system-view
[Huawei]sysname R1
[R1]interface GigabitEthernet 0/0/0 
[R1-GigabitEthernet0/0/0]ip address 1.1.1.1 30 
[R1-GigabitEthernet0/0/0]undo shutdown 
[R1-GigabitEthernet0/0/0]quit
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.1 24
[R1-GigabitEthernet0/0/1]undo shutdown
[R1-GigabitEthernet0/0/1]quit
[R1]interface GigabitEthernet 2/0/0 
[R1-GigabitEthernet2/0/0]ip address 3.3.3.1 30
[R1-GigabitEthernet2/0/0]undo shutdown
[R1-GigabitEthernet2/0/0]quit

R2

<Huawei>system-view
[Huawei]sysname R2
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 1.1.1.2 30
[R2-GigabitEthernet0/0/0]undo shutdown
[R2-GigabitEthernet0/0/0]quit
[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 2.2.2.1 30
[R2-GigabitEthernet0/0/1]undo shutdown
[R2-GigabitEthernet0/0/1]quit
[R2]interface GigabitEthernet 2/0/0
[R2-GigabitEthernet2/0/0]ip address 192.168.2.1 24
[R2-GigabitEthernet2/0/0]undo shutdown
[R2-GigabitEthernet2/0/0]quit

R3

<Huawei>system-view
[Huawei]sysname R3
[R3]interface GigabitEthernet 0/0/0
[R3-GigabitEthernet0/0/1]ip address 192.168.3.1 24
[R3-GigabitEthernet0/0/1]undo shutdown
[R3-GigabitEthernet0/0/1]quit
[R3]interface GigabitEthernet 0/0/1
[R3-GigabitEthernet0/0/1]ip address 2.2.2.2 30
[R3-GigabitEthernet0/0/1]undo shutdown
[R3-GigabitEthernet0/0/1]quit
[R3]interface GigabitEthernet 2/0/0 
[R3-GigabitEthernet2/0/0]ip address 3.3.3.3.2 30
[R3-GigabitEthernet2/0/0]undo shutdown
[R3-GigabitEthernet2/0/0]quit

PC’ler

PC1 : 192.168.1.2/24
PC2 : 192.168.2.2/24
PC3 : 192.168.3.2/24

Huwaie’de OSPF yapılandırması system-view modunda yapılır. Komut yapısı şu şekildedir: ospf process-ID router-ID.  Eğer process-ID ve router-ID verilmeden direkt OSPF işlemi başlatılabilir. Bu durumda sistem otomatik olarak ID numarasını 1 yapacaktır.  Router 1 için adım adım OSPF yapılandırmasını yapalım.

[R1]ospf 1 router-id 1.1.1.1

Ardından area belirlenir. Huawei’de area 32 bit olarak gösterilmektedir ama area belirtirken illaki 32 bit olarak yazılacak diye bir kural yoktur. Direkt ondalık biçimde yazılabilir.

[R1-ospf-1]area 0

Devamında routerın bildiği networkler Wild Card bitleri ile birlikte yazılır.

[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 1.1.1.0 0.0.0.3
[R1-ospf-1-area-0.0.0.0]network 3.3.3.0 0.0.0.3

Router 2 için

[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]network 1.1.1.0 0.0.0.3
[R2-ospf-1-area-0.0.0.0]network 2.2.2.0 0.0.0.3

Router 3 için

[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 2.2.2.0 0.0.0.3
[R3-ospf-1-area-0.0.0.0]network 3.3.3.0 0.0.0.3
[R3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255

Komutları yazarken kurulan OSPF komşulukları ile ilgili loglar CLI ekranına düşecektir.

ospf neighbor

Komşuluklar kurulduktan sonra sorunsuz bir şekilde uç networkler birbirleri ile iletişim kurabileceklerdir.

pc1 ping to pc2

OSPF Passive Interface

OSPF hello mesajları 10 saniyede bir gönderilir. Routerların birbirlerine bakan interfaceleri için bu gerekli olsa da, iç networke bakan interface için bu mesajların gitmesi gereksizdir. Bu mesajların iç networke gitmesi hem gereksiz trafik oluşturur, hemde manipülasyona neden olabilir. Bundan dolayı iç networke bakan interfaceler passive interface yapılmalıdır.

İlgili OSPF prosesi içerisinde silent-interface komutu ile, ilgili interface belirtilerek passive interface işlemi gerçekleştirilebilir.

[R1]ospf 1
[R1-ospf-1]silent-interface GigabitEthernet 0/0/1

[R2]ospf 1
[R2-ospf-1]silent-interface GigabitEthernet 2/0/0

[R3]ospf 1
[R3-ospf-1]silent-interface GigabitEthernet 0/0/1

OSPF Authentication (Kimlik Doğrulama)

OSPF komşuluğunda güvenlik amaçlı kimlik doğrulama (authentication) yapılabilir. Böylelikle kimlik doğrulama anahtarına sahip olmayan routerlar OSPF yapısına dahil olmaz. Kimlik doğrulama işlemi routerların birbirlerine bakan interfacelerine yapılır. Biz örnek olarak md5 ile kimlik doğrulamayı yapacağız.

Komut yapımız şu şekilde : ospf authentication-mode md5 Key-ID Password

Ben örneğimde Key-ID’si 1 olan ve parolası kisiselblog olan bir kimlik doğrulama yapacağım. Bu parametrelere sahip olmayan routerlar 40 saniye sonra komşuluktan düşecektir.

[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ospf authentication-mode md5 1 kisiselblog
[R1]interface GigabitEthernet 2/0/0
[R1-GigabitEthernet2/0/0]ospf authentication-mode md5 1 kisiselblog

Router 1 için parametreleri girdim. Bu parametreler diğer routerlar ile eşleşmediği için komşuluklar düşecektir.

ospf authentication down

Bu parametreleri diğer routerlarda da girdiğim zaman kısa bir sürede komşuluklar tekrardan kurulacaktır.

[R2]interface GigabitEthernet0/0/0
[R2-GigabitEthernet0/0/0]ospf authentication-mode md5 1 kisiselblog
[R2]interface GigabitEthernet0/0/1
[R2-GigabitEthernet0/0/1]ospf authentication-mode md5 1 kisiselblog

[R3]interface GigabitEthernet 0/0/1
[R3-GigabitEthernet0/0/1]ospf authentication-mode md5 1 kisiselblog
[R3]interface GigabitEthernet 2/0/0
[R3-GigabitEthernet2/0/0]ospf authentication-mode md5 1 kisiselblog

ospf authentication

Bazı OSPF display komutları

display ospf peer (komşulukları gösterir)

display ospf routing

display ospf interface

Yazacaklarım şimdilik bu kadar.  Bir sonraki konu da görüşmek dileğiyle.

Bir cevap yazın