eigrp

EIGRP (Enhanced Interior Gateway Routing Protocol)

EIGRP (Enhanced Interior Gateway Routing Protocol – Artırılmış Dahili Ağ Geçidi Yönlendirme Protokolü) : Cisco tarafından geliştirilen ve uzun bir süre Cisco tarafından kullanıldıktan sonra diğer firmaların da kullanımına sunulan; bandwidth (bant genişliği),  delay (gecikme), yük ve güvenirlik gibi metrik hesaplarını yaparak yönlendirme yapan dinamik yönlendirme protokolüdür.

Protokol çalıştığında, yönlendiriciler arayüzlerinden (interface) “Hello” paketi göndererek komşuluk kurarlar ve komşuluk tabloları oluştururlar. 5 saniyede bir komşu routera hello paketi gönderilir ve 15 saniye içerisinde cevap alınamazsa komşuluk silinir. Yapılan komşuluklar “Acknowledgement” paketi ile onaylanır. Query(sorgu) paketi ile ağda herhangi bir değişiklik olup olmadığı kontrol edilir ve gelen Reply(yanıt) paketine göre yeni tablolar oluşturulur. Tüm bu işlemler RTP (Reliable Transport Protocol – Güvenilir Taşıma Protokolü) ile gerçekleştirilir.

Yönlendirme tablosu yapılırken bir tane ana rota, bir tane de yedek rota yazılır. Böylece ana rotada herhangi bir problem olduğunda hızlıca yedek rotaya geçilir. Ayrıca yedek rotaya geçildiğinde de ayrıca yeni bir yedek rota daha hesaplanır.

EIGRP metrik hesabı nasıl yapılır? 

Metrik hesabında normalde 5 tane parametre bulunur (K1 : bandwidth ,K2 : load, K3 : delay, K4 :reliability, K5 : MTU (Maximum Transmission Unit))

fakat genellikle K1 (Bandwidth) ve K3 (delay) parametreleri kullanılır. Bu parametreler ön tanımlı olarak metrik hesabında tanımlanmıştır. Çok gerekli olmadıkça diğer parametrelerin aktifleştirilmesi tavsiye edilmez. Çünkü metrik değerlerin aynı olmaması durumunda yönlendiriciler arasında komşuluk kurulamayabilir.

Metrik hesabı (BW ve delay olduğunda)

Metrik = (Bandwidth + Delay) * 256

EIGRP’de eğer metrik değerler aynı değilse yönlendiriciler komşuluk kurmaz. Bu yüzden ön tanımlı ayarlar dışına çıkılmaması tavsiye edilir.

Bandwidth : Kaynak arayüzden (interface) hedef arayüze ulaşıncaya kadar geçilen arayüzler arasındaki en düşük bandwidth. (Burada bahsedilen ağın bant genişliği değil, arayüzlerin bant genişliği)

Delay (Gecikme) : Hedef ağa ulaşıncaya kadar geçilen tüm arayüzdeki gecikmelerin toplamı.

show ip protocols komutu ile metric hesabında hangi değerlerin hesaba katıldığı görülebilir.

Örnek;

EIGRP

EIGRP’ye geçmeden önce gerekli konfigürasyonları yapalım:

PC1 için;

IP : 192.168.1.10

SUBNET : 255.255.255.0

Gateway : 192.168.1.1

PC2 için;

IP : 192.168.2.10

SUBNET : 255.255.255.0

Gateway : 192.168.2.1

PC3 için;

IP : 192.168.3.10

SUBNET : 255.255.255.0

Gateway : 192.168.3.1

Router 1 için interface açma;

Router1#configure terminal

Router1(config)#interface gigabitEthernet 0/0

Router1(config-if)#ip address 192.168.1.1 255.255.255.0

Router1(config-if)#no shutdown

Router1(config)#interface serial 0/1/0

Router1(config-if)#ip address 10.10.10.1 255.255.255.0

Router1(config-if)#no shutdown

Router 2 için interface açma;

Router2#configure terminal

Router2(config)#interface gigabitEthernet 0/0

Router2(config-if)#ip address 192.168.2.1 255.255.255.0

Router2(config-if)#no shutdown

Router2(config)#interface serial 0/1/0

Router2(config-if)#ip address 20.20.20.1 255.255.255.0

Router2(config-if)#no shutdown

Router 3 için interface açma;

Router3#configure terminal

Router3(config)#interface gigabitEthernet 0/0

Router3(config-if)#ip address 192.168.3.1 255.255.255.0

Router3(config-if)#no shutdown

Router3(config)#interface serial 0/1/0

Router3(config-if)#ip address 10.10.10.2 255.255.255.0

Router3(config-if)#no shutdown

Router3(config)#interface serial 0/1/1

Router3(config-if)#ip address 20.20.20.2 255.255.255.0

Route3(config-if)#no shutdown

Gelelim EIGRP yapılandırmasına. Configure terminaldeyken router eigrp komutunu gireceğiz ve ardından 1 ila 65535 arasında bir numarayı otonom sistem numarası olarak verilecek. Verilen numara tüm yönlendiricilerde aynı kullanılmalı. Ayrıca routerları tanımlamak için bir ID’de tanımlanabilir. Id tanımlamak için IP adresi isteyecektir. Bu adres sisteme etki edecek bir adres olmadığı için ne verildiğinin önemi yok. Ama kolay hatırlanması açısından router hostnameye uygun bir isim olması daha iyi olur. Örnek; R1 routerı için 1.1.1.1 gibi.

Router 1 için yapılandırma;

Router1#configure terminal

Router1(config)#router eigrp 5 (5 numarası otonom numara. 1-65535 arasından istenilen sayı kullanılabilir.)

Router1(config-router)#eigrp router-id 1.1.1.1  (1.1.1.1 ile routera ID tanımladık.)

Router1(config-router)#network 10.10.10.0 (routerın bildiği networkleri tanımlıyoruz.)

Router1(config-router)#network 192.168.1.0   (routerın bildiği networkleri tanımlıyoruz.)

eigrp

Router 2 için yapılandırma

Router2#configure terminal

Router2(config)#router eigrp 5 (5 numarası otonom numara. 1-65535 arasından istenilen sayı kullanılabilir.)

Router2(config-router)#eigrp router-id 2.2.2.2  (2.2.2.2 ile routera id tanımladık.)

Router2(config-router)#network 20.20.20.0 (routerın bildiği networkleri tanımlıyoruz.)

Router2(config-router)#network 192.168.2.0  (routerın bildiği networkleri tanımlıyoruz.)

eigrp

Router 2 için yapılandırma

Router3(config)#router eigrp 5 (5 numarası otonom numara. 1-65535 arasından istenilen sayı kullanılabilir.)

Router3(config-router)#eigrp router-id 3.3.3.3 (3.3.3.2 ile routera id tanımladık.)

Router3(config-router)#network 10.10.10.0 (routerın bildiği networkleri tanımlıyoruz.)

Router3(config-router)#network 20.20.20.0 (routerın bildiği networkleri tanımlıyoruz.)

Router3(config-router)#network 192.168.3.0 (routerın bildiği networkleri tanımlıyoruz.)

eigrp

Router3’e 10.10.10.0 ve 20.20.20.0 ağlarını tanımlayınca protokol devreye girdi ve komşulukları sağladı.

show ip route komutu ile bakalım;

show ip route

Route tablosuna baktığımız zaman 192.168.1.0 ve 192.168.2.0 networklerinin EIGRP ile öğrenildiğini görüyoruz. EIGRP aktif olmasaydı, route tablosunda sadece routera direkt bağlı olan networkler görünecekti.

Şimdi bir de PC’den PC’ye ping atalım ve iletişimin olup olmadığını görelim.

PC3’ten PC1 ve PC2’ye ping attım ve herhangi bir problem olmadı.

Routerların networklere bakan interfacelerini pasif etmek gerekir. Çünkü Routerlar interfacelerinden Hello mesajları gönderecektirler. Networklere hello paketinin gitmesine gerek yok. Eğer pasif interface yapılmazsa boşu boşuna network ve diğer cihazlara da hello mesajı gönderilir ve gereksiz bir trafik yapılmış olur.

Router1(config)#router eigrp 5

Router1(config-router)#passive-interface gi0/0

Router2(config)#router eigrp 5

Router2(config-router)#passive-interface gi0/0

Router3(config)#router eigrp 5

Router3(config-router)#passive-interface gi0/0

show ip protocols komutu ile routerda kullanılan protokolleri görebiliriz.

show ip protocols

show ip eigrp neighbors komutu ile kurulan komşuluklar görüntülenebilir.

show ip eigrp neighbors

salih

hazırlanıyor...

Yorum Bırak

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir