Cisco HSRP Konfigürasyonu

single-image

Cisco tarafından geliştirilen ve Cisco’ya özel olan  HSRP (Hot Standby Router Protocol) protokolü, router  yedeklilik için geliştirilmiş olan bir protokoldür . Birden fazla routerın tek bir router gibi davranmasını sağlar. Bunun için de sanal IP adresi oluşturulur ve bu sanal IP gateway olarak işlev görür.  Routerlardan bir tanesi active(ana) router seçilir ve diğeri standby(yedek) olarak seçilir. Trafik active router üzerinden geçer ve active routera bir şey olması durumunda standby router devreye girer. Böylece trafik akışı minimal düzeyde kesintiye uğrayarak devam eder.

Routerlar arasında 3 saniyede bir ‘hello’ mesajları gönderilir. 10 saniye boyunca active router’dan cevap gelmemesi durumunda standby router görevi üstlenir ve active router olarak işlev yapmaya başlar. HSRP active router seçimi priority (öncelik) değerine göre belirlenir. Priority değeri yüksek olan router, active router seçilir. Priority değerinin aynı olması durumunda ise, yüksek IP adresine sahip olan router, active router olarak seçilir.

cisco hsrp configuration

HSRP yapılandırması için yukarıda bulunan basit örnek üzerinden gidelim.

VRRP yapılandırmasına başlamadan önce Router interface’lerine IP adreslerini verelim.

R1 interface yapılandırması

interface Ethernet0/0
ip address 192.168.10.253 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.20.253 255.255.255.0

R2 interface yapılandırması

interface Ethernet0/0
ip address 192.168.10.254 255.255.255.0
!
interface Ethernet0/1
ip address 192.168.20.254 255.255.255.0

PC’ler için yapılandırma

PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1
PC2 : 192.168.20.10 255.255.255.0 gateway 192.168.20.1

Interface yapılandırmasından sonra ilgili interface’lere girip HSRP yapılandırmasını yapıyoruz. Burada ilgili interface’lerde sanal IP adresini aynı yapmamız gerek. Ben 192.168.10.0 networkü için 192.168.10.1’i, 192.168.20.0 networkü için 192.168.20.1 IP adresinin kullanacağım.

Interfaceye girelim.

R1(config)#interface ethernet 0/0

standby ? yaptığımızda HSRP için kullanılabilecek parametreler gösterilecektir.

vhsrp options

Yapılandırma için ilk önce grup numarası isteyecektir. 0-255 arasında bir değer verebiliriz. Yalnız vermiş olduğumuz bu grup numarasını diğer routerda da aynı vermemiz gerekecek. Ben grup numarası olarak 10’u kullanacağım. Grup numarasını yazdıktan sonra tekrar soru işareti ile hangi parametreleri kullanabileceğimize bakalım.

R1(config-if)#standby 10 ?

hsrp group number options

Kullanılabilecek birçok parametre bulunmakta. Biz temel ayarları yapacağız. Öncelikle sanal IP adresini tanımlayacağım. 192.168.10.0 networkü için 192.168.10.1 adresini kullanacağım.

R1(config-if)#standby 10 ip 192.168.10.1

Ben R1 routerının birinci router olmasını istediğim için priority değerini yükselteceğim. Böylece R1 routerı üzerinden trafiğin akmasını sağlayacağım. Priority değeri olarak 0-255 arasında değer girilebilmekte. Varsayılan olarak değer 100’dür. Bu değer ne kadar yüksek olursa öncelik daha da artar. R1 için priority değerini 200 yapacağım.

R1(config-if)#standby 10 priority 200

Öncelik değeri R1’de yüksek olduğu için R1 active router olacak ve trafik bu router üzerinden gidecektir. R1’de bir problem olması durumunda R2 görevi üstlenecek ve trafik R2 üzerinden gidecektir. Eğer R1 tekrardan aktif duruma geçtiğinde trafiğin bu router üzerinden geçmesini istiyorsak preempt komutu ile bunu belirtmemiz gerekiyor.

R1(config-if)#standby 10 preempt

Böylelikle R1 routerının 192.168.10.0’lı network için ilk yol olduğunu ve R1’de bir problem oluşmasından sonra tekrar ayağa kalktığında trafiği tekrardan üstleneceğini belirtmiş olduk.

R2 için de 192.168.10.0’lı network için HSRP yapılandırmasını yapalım.

R2(config)#interface et0/0
R2(config-if)#standby 10 ip 192.168.10.1

192.168.10.0’lı network için R1 ve R2’de yapılandırmamızı yaptık. 192.168.20.0 networkü için de Router’larda yapılandırmamızı yapalım.

R1(config)#interface ethernet 0/1
R1(config-if)#standby 20 ip 192.168.20.1
R1(config-if)#standby 20 priority 200
R1(config-if)#standby 20 preempt
!
R2(config)#interface ethernet 0/1
R2(config-if)#standby 20 ip 192.168.20.1

Basitçe yapılandırmayı yaptık. 10’lu ve 20’li network için R1 routerı öncekli oldu.

Şimdi show komutları ile nelere bakabiliriz onları görelim.

show standby

show standby

Çıktıya baktığımızda; HSRP durumunu (active/standby), sanal IP ve MAC adresini, priority ve preempt durumunu görebilmekteyiz.

Daha kısa bir çıktı isteniyorsa eğer, show standby brief komutu kullanılır.

show standby brief

show standby neighbors

show standby neighbors

Aynı komutları R2’de de çalıştıralım:

show standby

show standby

show standby brief

show standby brief

show standby neighbors

show standby neighbors

Son olarak yedeklilik testimizi yapalım. VPC1(192.168.10.10)’den VPC2(192.168.20.10)’ye sürekli ping atacağım ve bu esnada R1 routerını yeniden başlatacağım. Böylece kesinti esnasındaki iletişimi görmüş olacağız.

Kesinti yapmadan önce VPc1 ile VPC2 arasındaki rotaya bakalım.

hsrp trace test

trace komutuyla yolu izlediğimizde trafik 192.168.10.253 üzerinden yani R1 üzerinden gidiyor. Seri ping atmayı başlattıktan sonra R1’i yeniden başlatacağım ve ardından rotaya yeniden bakalım:

hsrp trace test

Gördüğünüz gibi R1 ile R2 arasındaki geçiş o kadar hızlı olmuş ki kesinti bile yaşamadan trafik R2 üzerinden geçmeye başlamış.

Bu yazımızda HSRP ile router yedekliliğini yapmış olduk. Bir sonraki yazıda görüşmek dileğiyle…

 

Leave a Comment

Your email address will not be published.

You may like